天体などの表示

天体データ更新で「軌道要素ファイルへの書き込みができません」とエラーが出る

「データ更新」ダイアログで「更新を実行する」をクリックした後、「軌道要素ファイルへの書き込みができません」などのエラーメッセージが出てデータ更新が正常に完了しない。

ステラナビゲータのデータファイルが何らかの原因で不整合になったために問題が起こっている可能性があります。お手数ですが、以下の手順でステラナビゲータの設定をリセットしてみてください。
(※お客様が場所設定や色の変更、軌道要素編集などをされている場合、この手順により全てインストール直後の初期状態に戻ります。)

  1. [設定]メニュー→[環境設定] で[環境設定]ダイアログを開きます。
  2. 「ユーザデータを削除して終了」をクリックします。
  3. ステラナビゲータが終了しますので、再度起動します。
  4. [ツール]メニュー→[データ更新]から、データ更新が正常に行えるかどうかをご確認ください。

[環境設定]ダイアログで「ユーザデータを削除して終了」
[環境設定]ダイアログで「ユーザデータを削除して終了」をクリック

天体データ更新で「サーバに接続できません」とエラーが出る

「ツール」→「データ更新」ダイアログで「更新をスキャンする」をクリックすると、「サーバに接続できません。インターネットへの接続が完了しているか確認してください。」というエラー表示が出て天体データの更新ができない。

「サーバに接続できません」エラー

PC がインターネットに接続されていない、あるいはインターネット接続の設定に問題がある可能性があります。以下の対処をお試しください。

● インターネット接続の確認

Internet Explorerなどのウェブブラウザでインターネットのウェブサイトを開いてみます。正常に表示されない場合、お使いのPCがインターネットに接続されていないために問題が起こっている可能性があります。

● データ更新のネットワーク設定の確認

インターネットに接続されているはずなのにやはり問題が起こるという場合、ステラナビゲータの「データ更新」ダイアログで「更新方法:インターネット」の横の表示を確認します。

「データ更新」ダイアログを確認

もし「通常接続」ではなく「プロキシ接続」となっていれば、以下の方法で接続設定を変更します。

  1. 「データ更新」ダイアログの「設定」ボタンから「データ更新設定」ダイアログを開きます。
  2. 「代理サーバを使用する」のチェックをオフにして、「OK」ボタンで「データ更新設定」ダイアログを閉じます。
  3. 「データ更新」ダイアログに戻るので、「更新をスキャンする」をクリックして正常にデータ更新できるかどうかを確認します。

天体データ更新で配信されない天体を星図に表示したい

「ツール」メニュー→「データ更新」で実行できる天体データ更新では、彗星や小惑星などの太陽系小天体や突発天体のデータを随時オンラインでアップデートすることができます。

このデータ配信に含まれていない彗星・小惑星に関しては、手動で軌道要素データを追加・編集することで表示できます。

【軌道要素の編集・追加手順(例:彗星)】

  1. NASAその他のウェブサイトや天文雑誌等で、追加したい彗星の軌道要素(認識符号/離心率/軌道傾斜角etc.)情報を入手します。
  2. ステラナビゲータの「天体」メニュー→「彗星」ダイアログを表示します。
  3. 新しく彗星データを追加したい場合には「新規」、既存の彗星のデータを更新したい場合には該当の彗星を選択して「編集」をクリックします。
  4. 入力が完了したら「OK」をクリックします。

詳細につきましては、上記手順で表示される「軌道要素編集」ダイアログの「ヘルプ」ボタンからヘルプをご覧ください。

軌道要素編集ダイアログ
「軌道要素編集」ダイアログで、彗星データを新規追加する。

「系外惑星を持つ恒星」を星図に表示するには?

「系外惑星を持つ恒星」を星図に表示するには、ステラナビゲータの「天体」メニュー→ 「恒星」ダイアログ→「系外惑星を持つ恒星」をオンにします。データは「ツール」→「データ更新」で随時更新されます。

アストロアーツ天文ニュースなどの古いWeb記事で「コンテンツ・ライブラリからファイルをダウンロードしてください」といった案内がありますが、これはステラナビゲータVer.9以前の仕様に合わせた記述です。

「恒星」ダイアログで「系外惑星を持つ恒星」表示をオンにする
「恒星」ダイアログで「系外惑星を持つ恒星」表示をオンにする

太陽や月が歪んで表示される

ステラナビゲータ10ではVer.9とは異なり、太陽・月の形が視野周縁部ではややつぶれた楕円形状となります。これは、より正確なシミュレーションに即した表示とするための仕様です。

星図画面はスクリーンの下端中央を中心とする正距方位図法で表示されており、上端や左端、右端に近づくほど歪みが大きくなります。Ver.9では特別に太陽と月を円形で描いていましたが、この描画では背景の星空と辻褄が合わなくなるため、今バージョンのような表示としています。

ステラナビゲータ9と10での表示の違い
ステラナビゲータ9と10での表示の違い

星図画面が出ない、画面が乱れる

お使いのPCによっては、グラフィック環境がDirect3Dにフル対応していないため、星図画面が全く表示されなかったり、画面が乱れたりすることがあります。

この場合には、お使いのPCのグラフィックドライバを最新のものに更新してみてください。

それでも改善しない場合や、グラフィックドライバの更新ができない場合、残念ながらお使いのPCでステラナビゲータ10はお使いいただけませんので、誠に恐れ入りますが別のPCにインストールしていただくなどお願いいたします。

視野円・写野角が表示されない

ステラナビゲータの内部では視野円や写野角の位置を「赤経・赤緯」で保存するため、

などの操作を行うと枠の位置がウィンドウの外になってしまい、画面に現れなくなることがあります。

以下の手順で画面中央に戻りますのでお試しください。

  1. リボンバーから[視野・写野]タブを開きます。
  2. [=視野円=】の[表示]ボタン(写野角の場合は[=写野角=]の[撮像エリア]ボタン)を押して視野円または写野角の表示をオンにします。
  3. この状態で画面内に表示されない場合には、PCの[Shift]キーを押しながら[表示]ボタン(または[撮像エリア]ボタン)をもう一度クリックしてください。
    Shiftキーを押しながらクリック
    Shiftキーを押しながらクリック

この操作で視野円または写野角が画面の中央に戻ります。

これでも復帰しない場合には、[編集]メニューの[初期化]でいったん設定をすべてリセットすれば画面中央に表示されるようになります。

馬頭星雲やカリフォルニア星雲が表示されない

設定を変更することで名称やマークを表示できますが、これらの天体については画像は表示されません。

星雲・星団については、初期状態では明るさが0〜12等の範囲の天体のみマークや番号・通称などが表示される仕様になっています。

馬頭星雲(IC 434)やカリフォルニア星雲(NGC 1499)はカタログ上の光度が12等よりも暗いため、初期状態では表示されません。[天体]メニューの[星雲・星団]ダイアログ(またはリボンバーの[星雲・星団]タブ)で、[等級:]の[□限定]をオフにしていただくと、これらの暗い星雲も表示されるようになります。

また[星雲・星団]の設定で[画像]ボタンをオンにすると、プレアデス星団(すばる)やヘルクレス座の球状星団M13など主なメシエ天体については画像が表示されますが、馬頭星雲やカリフォルニア星雲などについては画像データが収録されていないため、[画像]のオン/オフに関わらず表示されません。

馬頭星雲の表示
リボンバー[星雲・星団]タブから表示設定を変更

はくちょう座デネブなど恒星の距離が参照方法によって異なる

ステラナビゲータで表示される恒星までの距離が、参照方法により大きく異なることがあります。これはそれぞれデータの出典が違うためです(参照方法ごとのデータの出典は下記)。いずれもステラナビゲータのデータ作成時点で最新のものを採用していますが、改訂時期が異なることやカタログのオリジナルの値を尊重しているため、一部に不統一が生じております。

どのデータがより新しい(より信頼性が高い)かや、デネブやアンタレス等ひじょうになじみ深い天体の距離だけでも何らかの形でわかりやすくできないか対応を検討してまいります。ご不便をおかけしますが何卒ご了承ください。

[星雲・星団]−[PGC]で表示される銀河の画像が実際の銀河の姿と異なる

この機能で表示される銀河の画像は模式的なイメージであり、実際の銀河の形状や傾きとは異なります。実際の銀河の形状を表示したい場合には[天体]−[DSS 画像取得]をご利用ください。

PGCで表示される銀河
PGC画像表示オンでの画面

DSS画像を重ねたところ
同じ領域でDSS画像を表示した画面

[星雲・星団]−[PGC]で表示される銀河の位置や天体情報パレットのデータが星雲星団マークの位置やデータと異なっている

PGCの銀河と従来の星雲星団マークとでは、データの出典(カタログ)が異なっているために座標や等級の値が一致しない場合があります。

ステラナビゲータの惑星の位置精度はどのくらいか?

ステラナビゲータの内部で計算される月・惑星の位置は、紀元前3000年から西暦3000年までの範囲については摂動を考慮した計算で求められています。この範囲内では、地球から見た月・各惑星の位置はNASA/JPLの天体暦DE406と比較して位置座標の誤差が1秒以内に収まっています。

上記以外の日時範囲ではこれよりも精度を落とした計算を行っていますが、歴史上記録が残っている時代に起こった日食等の天文現象を正確に再現できる程度には十分な計算精度を持っています。有史時代を超える数万年スケールの過去や未来の惑星位置については未検証です。

西暦1582年10月4日の翌日が10月15日に飛んでいる

ステラナビゲータでは1582年10月15日を境にしてユリウス暦とグレゴリオ暦を切り替えているため、1582年10月4日の翌日が10月15日となります。

「ユリウス暦」と「グレゴリオ暦」についての詳細はアストロアーツサイト内「星空ガイド」の「天文の基礎知識」コーナーにも掲載されています。

日時を数千年前(後)に設定した場合の天体位置の精度はどのくらいか?

遠い過去や未来における天体位置の精度に影響を及ぼす要因としては、歳差運動、固有運動、極運動、地球自転の減速などが考えられます。

ステラナビゲータ10ではこれらの要素については以下のような扱いとなっております。

(1)歳差運動
ステラナビゲータ10では、(A.D.2000±3000年)程度の範囲についてはNewcombの方法によって歳差を計算します。この方法の誤差の大きさは未検証ですが、およそ角度の分程度の精度はあるものと思われます。
(2)固有運動
ステラナビゲータ10ではHipparcos星表をベースにした基本恒星データを用いています。このHipparcos星表は固有運動の視線方向成分のデータを持たないため、固有運動については横断速度成分のみでの単純な計算にとどまっています。しかし±3000年程度であれば、太陽近傍のわずかな星を除いて誤差は無視できる範囲であると思われます。
(3)極運動
ステラナビゲータ10の天体位置には極運動は考慮されておりません。
(4)地球自転の変動
ステラナビゲータ10では、地球の自転速度の変動による時刻の変化ΔT(DT-UT)については、西暦1972年〜現在については厳密な値を使用しており、西暦1972年より以前のΔTと未来のΔTについてはNASAが提供している「5000年日食予報」と呼ばれるデータに含まれているΔTの推定値を使って計算を行っています。
西暦1972年より以前と未来の具体的なΔTの値は下記のPDFに掲載されていますので、ご参照ください。

NASA/TP.2009.214174
Five Millennium Catalog of Solar Eclipses:
-1999 to +3000 (2000 BCE to 3000 CE) - Revised
Fred Espenak and Jean Meeus
http://eclipse.gsfc.nasa.gov/5MCSE/TP2009-214174.pdf

なお、太陽系天体につきましては「よくある質問と回答」の「Q:ステラナビゲータの惑星の位置精度はどのくらいか?」を参照してください。

「卑弥呼日食」のシミュレーション結果が、テレビ番組や本で紹介されていたものと違う

これは当時の「地球の自転速度」が正確にはわかっていないため、それぞれ異なる自転速度を仮定して計算しているためです。

西暦248年に起こったといわれる、いわゆる「卑弥呼日食」は、ステラナビゲータのメニュー[お気に入り]→「歴史上の天文現象」→「部分日食『卑弥呼日食』」から再現できます。

テレビ番組や本で紹介されている「卑弥呼日食」と同じ時刻・場所をステラナビゲータに設定した場合でも、日食の時刻や太陽の欠け方が番組や本の結果と異なる場合があります。これは、番組や本での計算とステラナビゲータ10内部での計算とで、大昔の「地球の自転速度」に異なる値を採用しているために起こるものです。

私たちが日常使っている時刻系(世界時)は、生活に密接な昼夜のリズムに合わせるため、常に地球の自転に同期していますが、実際の地球の自転速度は一定ではなく、時代とともに早くなったり遅くなったりします。

したがって、過去の日食が起こる時刻を正確に計算するためには、その当時の地球がどのくらいの速さで自転していたかを知る必要があります。

天文計算では、この「地球の自転速度の変化」を表す値として、

の差が何秒あるか、という値を使い、これを「Δ(デルタ)T」と呼んでいます。

しかし、ΔTの値が実際の観測などによって明らかになっているのは過去400年間分程度にすぎません。それより昔の日食についてシミュレーションする際には、当時のΔTが何秒だったかを「仮定」する必要があります。

ステラナビゲータ10では、地球の自転速度の変動による時刻の変化ΔT(DT-UT)については、西暦1972年〜現在については厳密な値を使用しており、西暦1972年より以前のΔTと未来のΔTについてはNASAが提供している「5000年日食予報」と呼ばれるデータに含まれているΔTの推定値を使って計算を行っています。

西暦1972年より以前と未来の具体的なΔTの値は下記のPDFに掲載されていますので、ご参照ください。

NASA/TP.2009.214174
Five Millennium Catalog of Solar Eclipses:
-1999 to +3000 (2000 BCE to 3000 CE) - Revised
Fred Espenak and Jean Meeus
http://eclipse.gsfc.nasa.gov/5MCSE/TP2009-214174.pdf

卑弥呼日食については「星ナビ」2001年6月号でも特集しています(バックナンバーもお求めになれます)。

標高の高い観測地での大気差は正しく考慮されているか?

はい。ステラナビゲータ10では、観測地の標高が高くなるにつれて浮き上がりが少なくなるような仕様となっています。

限界等級を暗くしていくと暗い恒星の表示数が頭打ちになる

ステラナビゲータ10では、[恒星]ダイアログやステラパッドで限界等級をそれぞれ、

まで設定することができますが、実際にはGSC-ACTを使用した場合には約14等、Tycho-2を使用した場合には約11等で暗い星の表示数は頭打ちになります。これはそれぞれの恒星カタログに収録されている恒星の数自体が、この付近の等級を境にして減っているためです。

特定の赤経・赤緯の位置を画面の中央に表示させるには?

以下の手順で特定の座標を画面中央に表示させることができます。

  1. [視野]メニューの[中心座標を指定...]を開きます。

    名前で検索ダイアログ

  2. [座標系:]にお好きな座標系を選択し、[座標:]の欄に目的の座標値を入力します。
  3. [OK]ボタンで[中心座標を指定]ダイアログを閉じます。

地平座標で南が「方位角0度」になっているのはなぜ?

ステラナビゲータでは地平座標の方位角(azimuth)を表す際に、初期状態では南を「0度」としています。

地平座標の方位角の原点については北を0度とする場合と南を0度とする場合があり、天文計算の文献などでも両方のケースがあります。

南を0度とする流儀は、天体の「時角」が南側の子午線から測るように定義されていることから、これとの整合性を考慮して用いられてきたようですが、現在では北を0度とする場合も多くなっています。

ステラナビゲータ10では、[ツール]−[天体情報パレット設定...]の[表示オプション:]で「方位を南を0度にして表示」のチェックをオフにしていただければ、北を0度として表示することができます(ただし画面下部のステータスバーに出る方位は常に南が0度となります)。

天体情報パレット設定ダイアログ

限界等級を暗くすると動作が重くなることがある

ステラナビゲータでは、星の限界等級を大幅に暗くすると描画する恒星の数が極端に多くなるため、動作が重くなることがあります。

例えば、視野範囲が広い状態で表示等級を 15 等などに指定すると、何億もの星(USNO-A2.0星表をお使いの場合)を描画する事となり動作にかなりの時間を要するため、場合によってはソフトがフリーズしてしまう事もあります。

そのような場合は、視野範囲を狭く(数度程度)していただいてから表示等級を暗くすると正常に表示することが出来ます。

●対処法

描画する恒星が多すぎて描画に時間がかかる場合、ウィンドウの右下部にプログレスバーが表示されます。

この状態になった場合には [ESC]キーを押して頂くことで強制的に描画を中断することができ、ソフトのフリーズを防ぐことが出来ます。

※一度 [ESC]キーを押しても描画が止らない時には、[ESC] キーを何度か押してみてください。

→描画が中断されると、描画途中の絵が表示されます。

※描画が中止された状態でも、アニメを実行したり視野範囲を変更したりすると、その度に描画を繰り返し行いますのでお気をつけください。

上にもどる